使用路由器的Loopback接口地址作为Route ID,R1的Loopback0为1.1.1.1/32,R2的Loopback0为2.2.2.2/32,R3的Loopback0为3.3.3.3/32,R4的Loopback0为4.4.4.4/32.

使用Loopback接口模拟下带主机的地址网段,R1的Loopback1为192.168.1.0/24,R2的Loopback1为192.168.2.0/24,R3的Loopback1为192.168.3.0/24,R4的Loopback1为192.168.4.0/24

R1(config)#interface fastEthernet 0/0

R1(config-if)#ip address 10.0.0.9 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)#ip address 10.0.0.5 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 2/0
R1(config-if)#ip address 10.0.0.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface loopback 1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 10.0.0.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface loopback 0
R2(config-if)#ip address 2.2.2.2 255.255.255.255
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface loopback 1
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 10.0.0.6 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback 0
R3(config-if)#ip address 3.3.3.3 255.255.255.255
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface loopback 1
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 10.0.0.10 255.255.255.252
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 0
R4(config-if)#ip address 4.4.4.4 255.255.255.255
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 1
R4(config-if)#ip address 192.168.4.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#router-id 3.3.3.3
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0
R3(config-router)#network 10.0.0.6 0.0.0.0 area 0
R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
R3(config-router)#exit
R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 2.2.2.2 0.0.0.0 area 1
R2(config-router)#network 10.0.0.2 0.0.0.3 area 1
R2(config-router)#network 192.168.2.0 0.0.0.255 area 1
R2(config-router)#exit
R4(config)#router ospf 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 4.4.4.4 0.0.0.0 area 2
R4(config-router)#network 10.0.0.10 0.0.0.0 area 2
R4(config-router)#network 192.168.4.0 0.0.0.3 area 2
R4(config-router)#area 2 stub
R4(config-router)#exit
R4(config)#ip route 0.0.0.0 0.0.0.0 10.0.0.9
R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.0.0.1 0.0.0.0 area 1
R1(config-router)#network 10.0.0.5 0.0.0.0 area 0
R1(config-router)#network 10.0.0.9 0.0.0.0 area 2
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#exit
R1(config)#do show ip route
     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/2] via 10.0.0.2, 00:03:25, FastEthernet2/0
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/2] via 10.0.0.6, 00:01:22, FastEthernet1/0
     4.0.0.0/32 is subnetted, 1 subnets
O       4.4.4.4 [110/2] via 10.0.0.10, 00:00:41, FastEthernet0/0
     192.168.4.0/32 is subnetted, 1 subnets
O       192.168.4.1 [110/2] via 10.0.0.10, 00:00:41, FastEthernet0/0
     10.0.0.0/30 is subnetted, 3 subnets
C       10.0.0.8 is directly connected, FastEthernet0/0
C       10.0.0.0 is directly connected, FastEthernet2/0
C       10.0.0.4 is directly connected, FastEthernet1/0
C    192.168.1.0/24 is directly connected, Loopback1
     192.168.2.0/32 is subnetted, 1 subnets
O       192.168.2.1 [110/2] via 10.0.0.2, 00:03:27, FastEthernet2/0
     192.168.3.0/32 is subnetted, 1 subnets
O       192.168.3.1 [110/2] via 10.0.0.6, 00:01:24, FastEthernet1/0
R1(config)#do ping 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/45/60 ms